[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[no subject]

hi everyone,
   i've got another newbie question:

== Problem == i can't find the sr_mod module in 2.4.18-bf2.4 kernel

== Context == i'm trying to get cdrecord to work.
- i've read and tried to apply CD-Writing-HOWTO.html  v2.9.3, 23 July 2000

== Attempted diagnosis == 
me@host$ ## sg etc. seem OK
me@host$  grep "^........ sg_" /proc/ksyms  
ce88fe20 sg_big_buff    [sg]
me@host$ grep "^........ sr_" /proc/ksyms 
me@host$ insmod sr_mod
insmod: sr_mod: no module by that name found

It seems to me the module sr_mod is missing. Any idea where i find it?

i tried 
   apt-cache search scsi
on the closest thing i could find was sg3-utils, which i installed,
but it didn't seem to provide sr_mod.

This seems to be the directory where sr_mod.o should be found:

me@host$ ls /lib/modules/2.4.18-bf2.4/kernel/drivers/scsi/
AM53C974.o  atp870u.o   fdomain.o    initio.o     qlogicfc.o   sym53c416.o
a100u2w.o   cpqfc.o     g_NCR5380.o  megaraid.o   qlogicisp.o  sym53c8xx_2/
advansys.o  dtc.o       gdth.o       osst.o       seagate.o    t128.o
aha152x.o   eata.o      ide-scsi.o   ppa.o        sg.o         u14-34f.o
aha1542.o   eata_dma.o  imm.o        psi240i.o    sim710.o     ultrastor.o
aha1740.o   eata_pio.o  in2000.o     qlogicfas.o  st.o         wd7000.o

The CD-Writing-HOWTO.html v2.9.3 just says:
> Installing the resulting Linux-kernel is beyond the scope of this HOWTO.
> Please consult the documentation of your Linux-distribution.
> Users of RedHat Linux be aware that you have to compile in the features
> "Ramdisk support" and "Initial ramdisk". Furthermore, you have to
> generate a new ramdisk with the new modules by issuing a command like
> "mkintrd --preload ide-cd initrd-2.2.14.img 2.2.14".

any ideas?

Bądź blisko bliskich! Rozmawiaj przez Kontakt!
Kliknij i ściągnij nową wersję! < http://kontakt.wp.pl/ >

Reply to: