[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lexmark Z65 on debian?



ernst wrote:

I have just got a lexmark Z65 and now I can't print to it. I have search
the net for info, and some sites says the printer i linux

The printer has it's own nic, and I have attached the printer directly to
a switch. When I do the procedyre for printing out the "info
page"(directly from the printer,not over network) I get
the MAC addr. and IP addr. It has also been given the IP for the correct
nettwork. I need to set a static ip, and from the dhcp it's an reserved IP
for the printer.
But you can't ping to it, from either the Windows box or the Debian box? Then something's wrong in your network. Bad NIC, bad cabling, bad numbers . . .

OK, the senario is that the printer is still attached to the net from it's
own nic, and from an windoze9x box I have also tried to share it and print
via the windoze box, with no luck.

The strange thing is how windoze commuticate withe the printer, even if I
know it got an IP, I cant Ping or nmap it! But I was able to use arp to
set an IP addr.

But with samba, you meed that I scould install the printer on debian, and
then use samba to share it with windoze, insted of the other way around? I
have never done samba and printing, bunt nothing is impossible:)
Actually I meant the other way around, but Samba will go either way. You can attach it to the Windows box and share it and the Debian box can access it via Samba, or you cah attach it to the Debian box and share it with Samba and the Windows box can access it. But it my experience, Samba just adds complications (going either way), so I'd stick with printing to the IP address, once you get the networking issue (mentioned above) solved.

On the other hand, if the printer actually has a NIC attached to it, it
should work, but before chasing this path give us more info.


Yes, it scould be that easy, but no luck yet.

Here is my printcap file, and with this one I tried to print trough the
shared printer on a winobx with the ip x.x.x.16 to the printer "lexmark".
It gives me no error, but doesn't print.

lex|lexmark
       :rm=192.168.2.16:\
       :sd=/var/spool/lpd/lexmark/:\
       :rp=lexmark:\

Until you can ping or telnet to the printer, you'll not be able to print to it with this printcap file. I'm suspecting now that perhaps the switch you're going through has some router or firewall functions that's causing some blockage. Do you have the Winbox and DebBox attached to the same switch? If so, can they ping each other? If so, suspect a hardware problem on the printer segment. If you can acquire or make a "rolled" cable (aka "crossover cable"), try using it to connect the printer directly to one of the computers and trying pinging/telnetting to it. If that fails, suspect a bad NIC in the printer or something broken in the printer (or misconfigured).

Kent




Reply to: