[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

internet access using DHCP works only on windows

I have a 3COM Office Connect Remote 812 ADSL Router which seems to be
working perfectly. I say "seems to be working" cause it only works on my
windows 2000, which is configured as a DHCP client. My NIC is the infamous
realtek 8139. Already tried dhcpcd -d -r -h eth0 / pump / dhclient and
recompiled 2.4.18 with packet socket, socket filtering, etc None worked,
timeout errors.  Then I decided to reinstall linux.

When I try to install debian, I choose the eth0 interface and then select
dhcp / bootp to configure automatically. After ~1 minute, I got an error
message. I already tried to configure with the same IP information from
windows ( but not working too. My internet connection is NOT
via PPPoE nor pppoa, Im sure cause I dont need any username and password to
connect. Just plug, configure as dhcp client and surf.(wow). I have another
computer using this modem, so we can share the internet connection, but it
only works on windows too! Already updated the firmware and tried lots of
configurations in modem setup (accessible at but with no
luck. Searched everywhere a solution for this, Im almost giving up.
It just can't be any problem with my modem, cause it works "perfectly" on
windows. Is it a winmodem??

Thanks in advance

Reply to: