[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: No Screens Found error

Thanks mad, see later post on this thread for the solution from da spoon
that worked for me...
set: use kernel framebuffer device interface = no

This problem is all over Google by the way, and I didn't see this answer.

Best Wishes!
Mike Olds www.buddhadust.org

-----Original Message-----
From: Doug MacFarlane [mailto:madmac@covad.net]
Sent: Sunday, August 18, 2002 8:08 AM
To: Michael Olds; debian-user@lists.debian.org
Subject: Re: No Screens Found error

I had this same problem.  It's a problem with the configuration of your
typically XFree86.  You can try to reconfigure it properly using:

dpkg-reconfigure xserver-xfree86 (or xserver-XFree86, I can't remember).

and answering the questions differently.  This didn't work for me . . .

At any rate, this process creates the default X11 config file,

Or, you can let XFree86 try and configure itself, by issuing the command:

XFree86 -configure

This will create a file /root/XF86Config-4 that you can use instead of the
default above by issuing the XFree86 command directly at the command prompt
with the path to the /root/XF86Config-4 file as an option.  The -configure
command above will tell you what the exact format of this command is (I
be sure of my recollection).

At any rate, NIETHER of these worked for me.

dpkg-reconfigure couldn't get the monitor/display set right.
XFree86 -configure couldn't get my mouse settings right

But, by copying the mouse settings from /root/XF86Config-4 into
and editing the ServerLayout section properly (may not be necessary), I got
X working properly.

Ofcourse, now my XF86Config-4 isn't "debconf" compliant, so I might screw
it up if I re-ran dpkg -reconfigure, but I could straighten it out, I think
. . . .

Good Luck!!!


On 17 Aug 2002, 16:49:21, Michael Olds wrote:
> Greetings, new to the list, and new to Debian/Linux:
> I am installing 3.0 (Woody) on Intel 845 P4 1.6G; 768MbRAM; ATI Expert
> 2 20G WD Hard Drives Mouse, Keyboard and Monitor on KVM
> I went through what looked to me like an orderly install but after login I
> tried to get to the graphical desktop using: startx and got the following
> error: (this is the second install with the same problem, second time to
> what I thought was a simple configuration):
> (EE) Screen(s) found, but none have a usable configuration
> Fatal server error
> no screens found
> X10: fatal IO error 104 (connection reset by peer) on X server ":0.0"
> 0 requests (0 known processed) with 0 events remaining.
> Can someone tell me what is wrong here and what I can do to correct it? I
> very unfamiliar with using text mode and really need to get to the desktop
> before I can settle in to learning mode.
> Thanks in advance,
> MO

Doug MacFarlane

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: