[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CUPS not working & exim.conf blues ...



On Fri, Aug 16, 2002 at 03:04:17PM +1000, Adam Bogacki wrote:
> Hi there O Wise Ones,
> 
> I have tried to install CUPS via <http://localhost;631> and following 
> the prompts,
> logging in again as root ... until it gives me the message that the new
> Epson (Stylus Photo 700) has been connected but when I try to print the
> CUPS test page nothing happens.
> 
> I apt-installed the latest version cupsys (1.1.15-3) in case there was 
> a bug and tried again; 'lpq' showed nothing in the queue and having a 
> look at /etc/printcap showed it configured for a dot-matrix printer 
> rather than the Stylus Photo ink-jet.

cups should be using /etc/printcap.cups. The printer config files are
actually located in /etc/cups. /etc/printcap is probably left over
from before you installed cups. 

To help diagnose problems with cups, log files are in
/var/log/cups. You can set the LogLevel parameter in
/etc/cups/cupsd.conf to "debug" and restart the cupsd process to get
more output to the logs.

Have you tried "/etc/init.d/cups restart" to see if that corrects the
problem?

> I installed xpp  ... but no luck ... it is not writing to /etc/printcap.
> 
> I have the option of apt-installing the old RH favourite 'printtool' and 
> hoping that could do something with the script but I have previously 
> been successful with CUPS and would like to get it right.
> 
> I'd really like to get on top of this as soon as possible as I am 
> packing everyting at the moment before a move in two weeks time. I'd 
> send my /etc/printcap if exim was working ...
> 
> I have been getting the message "lookup of host "Primus" failed in 
> smarthost router" and going into /etc/exim.conf and trying
> 
> 'route_list = "* Primus bydns_a"
> 
> and
> 
> 'route_list = "* 203.134.64.66 byname"

How is the SMTP server identified in Mozilla-mail? It should probably
be the same in exim.conf. In my exim.conf it looks like:

route_list = * outgoing.verizon.net byname

Based on your email address I imagine yours maybe something like:

route_list = * xxx.primus.com.au byname

> 
> without luck.  'Mozilla-mail' has been sending and receiving without a 
> hitch.

-- 
Jerome

Attachment: pgpr04uEoo_tc.pgp
Description: PGP signature


Reply to: