[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: failed upgrade, urgent help needed


thanks for getting back to me.

I'll know that for next time.

it was getting crufty in there anyway and the data was on seperate
partitions so only a few hours lost, and many valuable lessons learned..

At 08:34 AM 8/11/02 +0100, Oliver Elphick wrote:
>On Sun, 2002-08-11 at 06:36, John Griffiths wrote:
>> hi, i've just tried to upgrade from a potato box running the 2.4.7 kernel
>> from the adrian bunk source
>> I think we fouled up upgrading apt-utils and didn't realise until we were
>> upgrading the kernel to 2.4.18
>> on boot lilo starts up but then we get a string of messages about kernel
>> modules and then it dies (kernel panic).
>> i'm making a boot floppy now
>> but any advice as to how to fix the problem would be massively appreciated
>boot in single user mode (at lilo prompt, enter "<linux> single",
>substituting the correct image name for <linux>).  If the failure still
>happens, boot to a shell "<linux> init=/bin/sh".  You can then start to
>repair things.  Your problem may be that you need to run "depmod -a" to
>build an up-to-date list of modules and dependencies.
>Oliver Elphick                                Oliver.Elphick@lfix.co.uk
>Isle of Wight, UK                            
>GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839  932A 614D 4C34 3E1D 0C1C
>                 ========================================
>     "But my God shall supply all your need according to his
>      riches in glory by Christ Jesus."    Philippians 4:19 

Reply to: