[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

alsa and crystal 4235 chipset



Hi,

I'm having troubles setting up alsa to work with the crystal 4235
chipset on a woody box.
According to the alsa-mini-HOWTO the chipset *is* supported.
It seems to be the snd-card-cs4236 alsa module that needs to be used.

Now setting this one up happens to be a problem, at least for me. The
HOWTO says the card needs parameters because it doesn't autoprobe.

First I apt-get installed all alsa modules and a couple of mixers.
I tried alsaconf and it put 

 options snd-card-cs4236 snd_index=0 snd_id=CARD_0 snd_port=0x534 \
 snd_cport=0x120 snd_mpu_port=0x300 snd_fm_port=0x388 snd_irq=11 \
 snd_mpu_irq=7 snd_dma1=1 snd_dma1_size=4 snd_dma2=3 snd_dma2_size=4

into /etc/modules.conf after asking me a couple of questions.
Now I haven't got a clue what irq's to specify or what a good dma size
would be.
According to the HOWTO only "snd_dma1=NN snd_dma1_size=NN" are rerquired
and the other parameters are optional. So I tried all combinations of

 optons snd-card-cs4236 snd_dma1=[013] snd_dma1_size=(4|8|16|32|64)

with no affect.
All I get is

 host:~# modprobe snd-card-cs4236
 /lib/modules/2.4.16-686/alsa/snd-card-cs4236.o: invalid parameter parm_snd_dma1_size
 /lib/modules/2.4.16-686/alsa/snd-card-cs4236.o: insmod /lib/modules/2.4.16-686/alsa/snd-card-cs4236.o failed
 /lib/modules/2.4.16-686/alsa/snd-card-cs4236.o: insmod snd-card-cs4236 failed

Even Googeling around for two hours didn't turn up any more usefull
information :(

Has anybody got any pointers, experiences or hints where to start looking for me?
Or maybe even some valid values?

Heaps of thanks!

Greetings,
-- 
Vinai
Registered Linux User #280755, Debian GNU/Linux  http://counter.li.org/
Secure eMail with gnupg                          http://www.gnupg.org/

Attachment: pgpTSe_fARFIZ.pgp
Description: PGP signature


Reply to: