[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ntpdate troubles

  Bill> Okay.  It works okay at boot time?

  Jerome> No !
  Jerome> It is why I debg it: I get exactly the samr message error in 
  Jerome> `/var/log/syslog'.

  Bill> When you ran it by hand to debug it, the command looked something
  Bill> like this, right?

  Jerome> without the -b , but with -d -v -B

Okay.  ntpdate with no REMOTE_MACHINE_NAME_GOES_HERE gives me
  no servers can be used, exiting

I chose a machine in my building and get
  adjust time server offset 0.000451 sec

I chose a building outside my building (which I probably can't
get to because of all our stoopid firewalls and got
  no server suitable for synchronization found

So I would guess this means that you cannot get to the machine
you are ntpdate'ing against.  You showed that it worked when you
did it against ntp.apple.com.  I assume that it also works when
you debug it by hand?  If so, I would guess that Joris'
suggestion is a good one:

  Joris> on my machine, I haven't got ntpdate to work out the
  Joris> hostnames of any ntp server. I just pinged them, copied
  Joris> the ip's and dpkg-reconfigure'd ntp to look for the
  Joris> ip's. It has worked ever since.

Meaning that ntpdate is using a hostname but resolve the hostname
into an IP...  I think... :-)


- Bill
Bill Benedetto     <bbenedetto@goodyear.com>    The Goodyear Tire & Rubber Co.
I don't speak for Goodyear and they don't speak for me.  We're both happy.

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: