[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help geting galeon re-installed

I'm in the process of recovering from a stupid mistake I made yesterday, thanks to several
helpful list memeberes who have used part of thier weekend to help me.

At the moment I'm in pretty good sahpe, except that I can't seem to get any veraion of galeon
installed :-(. Now since I use it as my primary web browser, this is problemeting/

The machine in question was a totaly woody machine, and I remeber seeing somewhere that galen
had been removed from woody in prperation for relase. So I copied the following preferences
file over from a ixed woodt/unstable machine:

Package: *
Pin: release a=testing
Pin-Priority: 900

Package: *
Pin: release a=stable
Pin-Priority: 500

Package: *
Pin: release a=unstable
Pin-Priority: 95

Here's the sources.list from the machine in question:

deb http://http.us.debian.org/debian stable main contrib non-free

deb http://http.us.debian.org/debian testing main contrib non-free
deb http://non-us.debian.org/debian-non-US testing/non-US main contrib non-free

deb http://http.us.debian.org/debian unstable main contrib non-free
deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free

deb ftp://ftp.tux.org/pub/java/debian/ woody non-free

As you cab see it does include unstable.

galeon, and galeon-beta both appera as options in dselect, but neither one of them will
install. I tried:

apt-get install galleon-beta/unstable

it sugested using galeon istead, so I tried:

apt-get install galleon/unstable

This said it dpeended on a newer version of mozilla, so I tried:

apt-get install mozialla/unstable

and got:

smokey:~# apt-get install mozilla/unstable
Reading Package Lists... Done
Building Dependency Tree... Done
Selected version 2:0.9.9-6 (Debian:unstable) for mozilla
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
 mozilla: Depends: mozilla-browser (= 2:0.9.9-6)
 Depends: mozilla-mailnews (= 2:0.9.9-6) but 2:0.9.8-2 is to be installed
Depends: mozilla-psm (= 2:0.9.9-6) but 2:0.9.8-2 is to be installed
E: Sorry, broken packages

What can I do to get galeon installed?

"They that would give up essential liberty for temporary safety deserve
neither liberty nor safety."
						-- Benjamin Franklin

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: