[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgraded to woody and printing from KDE stopped

  Based upon the kind advice of Steffen E., I installed apsfilter (and 
associated packages).   The Test Page prints from apsfilterconfig just 
great.  Alas, I still can't print from within KDE, getting the error 
/usr/bin/lpr -P 
'hl1240|laserjet';r=600x600;q=high;c=full;p=letter;m=auto '-#1'
/home/family/.kde/tmp-family/kdeprint_4h2doue: execution failed with

Status Information:  sending job 'family@localhost+579' to
connecting to 'localhost',attempt 1 connected to 'localhost' requesting 
printer hl1240|laserjet;r=600x600;q=high;c=full;p=letter;m=auto@localhost 
job 'family @localhost+579' transfer to
hl1240|laserjet;r=600x600;q=high;c=full;p=letter;m=auto@localhost failed 
'ACK_FAIL' sending str
'^Bhl1240|laserjet;r=600x600;q=high;c=full;p=letter;m=auto@localhost error 
msg: 'bad printer name'

   I must admit that the printer name looks screwy, but that's what the 
venerable apsfilter came up with.  :-)

  I also wonder if there's something in KDE/woody.  When installing, 
dselect reported a conflict between kghostview and  koffice-libs:
koffice-libs recommends kghostview (>= 2.2-0), but kghostview 2.1.1-6 is 
what's in woody.

   Again, thanks to Steffan for his initial help.  Alas, more is needed.  


On Friday 29 March 2002 04:34, Steffen Evers wrote:
> On Thu, Mar 28, 2002 at 21:54, Gruetzner wrote:
> >   I did a search to see if others have had this problem, but didn't
> > find any.  My apologies if I didn't use the right keywords.  I've
> > tried to use the printing HOWTO, but seem to be going in circles when
> > reading it.
> >
> >    I recently upgraded from potato to woody.  I did not upgrade the
> > kernel (2.2.19).  My desktop is KDE.
> >
> >     After upgrading, I could no longer get my printer to work.  (It
> > worked under potato:  I've a Brother HL-1240, and used the laserjet
> > driver.)   I have since installed lprng and deleted lpr, and can now
> > print an ascii file from the command line (e.g.,   lpr  testfile.txt).
> >   I
> >
> >     However, when I try to print from a KDE app or from WordPerfect or
> > from acrobat, I get the following type of message window popping up:
> >
> > --------------------
> > /usr/bin/lpr -P 'lp|bhl1240|Brother HL-1240' '-#1'
> > /home/family/.kde/tmp-family/kdeprint_s5dkMry: execution failed with
> > message:
> >
> > Status Information:  sending job 'family@localhost+433' to
> > lp"bhl1240|Brother HL-1240@localhost connecting to 'localhost',
> > attempt 1 connected to 'localhost' requesting printer
> > lp|bhl1240|Brother HL-1240@localhost job 'family @localhost+433'
> > transfer to
> > lp|bhl1240|Brother HL-1240@lcoalhost failed error "NONZERO RFC1179
> > ERROR CODE FROM SERVER' with ack 'ACK_FAIL' sending str
> > '^Blp|bhl1240|Brother-1240' to lp|bhl1240@localhost
> > error msg: 'bad command line'
> > ---------------
> >
> >    I'm at a loss.  I'm pretty ignorant of printing arcana, but
> > something must need configuring that isn't.
> >
> >     Oh, I've tried it with the environmental variable $PRINTER set to
> > "lp" and to just nothing:  same results.   I've also tried...
> >    # lpc enable all
> > ...with no change.
> >
> >    When I run lpq, it tells me that the last job that lp@localhost
> > printed was the  lpr testfile.txt, and that Filter_status: lp is ready
> > and printing.   (It's lying.)   (What's this "@localhost bit?)
> >
> >    Running lsmod shows that lp is apparently loaded.   I didn't see
> > anything that made sense to me in the /var/logs--but I may not know
> > what to look for!
> I have been on woody for a while, but ran my regular package upgrade
> lately which stopped my printing as well.
> My printer has still received data, but could not print what it got.
> After spending several hours on debugging I have found out that my
> current apsfilter settings (maybe you use the similar package
> magicfilter) were not compatible with the current gs package
> (ghostscript). After reconfigurating apsfilter with apsfilterconfig
> everything has been fine again. However, it was a little bit
> tricky to find a suitable printer driver that was supported in
> apsfilter AND the current gs package as apsfilter has not been adjusted
> to the recent changes in gs.
> Maybe that helps ...
> Good luck.
> Bye, Steffen

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: