[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Woody root on RAID and 2.4.17


>And then, once the RAID system is bootable, install the MBR to /dev/sdb as
># MBR's to which lilo will be installed
>raid-extra-boot=/dev/sda, /dev/sdb
>Am I getting this right?  I wouldn't like to trash the single-disk install

	What I did was get everything running in RAID mode
	except for /boot.  I compeletly RAIDed the root, swap,
	and other partitions except for /boot.  I rebooted
	and had everything but /boot running in RAID mode with
	the 'failed-disk' changed to 'raid-disk' and synced
	with the 'raidhotadd' command.  This includes updating
	/etc/fstab and lilo.conf.  In lilo.conf you need
	to point 'root=' to the RAID device and run lilo
	to update stuff, but don't change the 'boot=' field
	yet.  You need to do the fstab and lilo update before

	Once this was all working, I then did the RAID conversion 
	on /boot. The steps I took for /boot where:

		1) Shutdown 0 (to get to single user mode).

		2) Copy /boot to /dev/md0 (I created md0 when I created
		   the other RAID devices).

		3) Umount old /boot

		4) Mount /dev/md0 as /boot

		5) Edit /etc/fstab to point /boot at the RAID device.

		6) Edit lilo.conf to point /boot at the RAID devivce,
		   add the 'raid-extra-boot' line with BOTH

		7) Run lilo -vt (testing) and see if everything
		   looks okay.

		8) Then I ran lilo -v .

		9) Reboot.

		10) Once the system was up and running I finished
	 	    the RAID conversion of /boot.

		10a) Once the RAID conversion of /boot was done
		     I ran lilo -v again.  I don't think this is needed,
		     but I did it anyways.

	This worked for the first time for me.  Unlike
	what is documented in the HOWTO for booting
	from a RAID, which created an unbootable system :-( .

	For the above to work you need the latest lilo version
	(22.1) so check that before starting down this road.


Reply to: