[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing Debian


This is my first time on the debian lists and so please slap me in the
appropriate manner if I'm posting in the incorrect forum.

I decided to install Debian recently on my Slackware box. I partitioned
/dev/hdc to a linux partition at hdc1. I then grabbed the base2_2.tgz,
drivers.tgz files (for idepci) and dropped them on /dev/hdc1. I saw nothing
in the instructions about untarring them, and so I did not. I downloaded
the rescue-1.bin image and wrote it to floppy(dd). I then inserted it into
the floppy drive and rebooted. I get the Rescue Disk screen, with the
option to pass arguements.

When I do not pass arguements, I get a "Cannot open initial console. Try
passing init = to kernel" error. When I pass linux root=/dev/hdc1, I
receive the same.

Thinking I had misunderstood something, I untarred the driver and base
packages in /dev/hdc1. I rebooted and recieved an error saying that I was
attempting to use an unconfigured system, and had to run the install

I then tried passing linux root=/dev/hdc1 init=/install.sh

This seemed to execute the install program, but it errored on "file already
exists" for each step in its untar of base2_2.tgz.

Decided I wasn't meant to untar, cleaned off /dev/hdc1. I then untarred
only the driver package and left base2_2.tgz alone. Then I tried passing
linux root=/dev/hdc1 init=/install.sh. This brought me back to "Cannot open
initial console. Try passing...".

At this point, I know I'm just doing something utterly stupid. I will be
replacing my Slackware system with Debian if this ever works out for me.
Would appreciate any help that could be offered. Again, if this posting is
to the wrong group, please let me know.

Liam Black

Reply to: