[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


----- Original Message ----- 
From: "nate" <debian-user@aphroland.org>
To: <debian-user@lists.debian.org>
Sent: Monday, December 31, 2001 7:57 AM
Subject: Re: ADAPTEC 2040U2W PROBLEM

> <quote who="JM Vainio">
> > Hello!
> > scsi bus is being reset for host 0 channel 0.
> > scsi host 0 channel 0 reset (pid17) timed out - trying harder
> > scsi bus is being reset for host 0 channel 0.
> > scsi host 0 abort (pid17) timed out - resetting
> > scsi bus is being reset for host 0 channel 0.
> > (scsi0:0:0:0) device reset, message buffer in use
> > Is anyone here familiar with this kind of issues?
> yep i had that occur on my 2 intel ISP2150 servers.
> the workaround is to tell the driver not to reset
> the card, its a kernel option you type when you
> boot the system at the boot: prompt. navigate through
> the help screens and it will be there, its something
> like
> aic78xxx=no_reset

Well, I found that option and I tried it. The result was that the installer did recognize the SCSI bus and every disk connected to it. But after that, the installer still went on resetting the bus (despite the fact that I had told the driver not to reset). That was to happen after the "partition check" of the SCSI disk 0. The installer did recognize the physical capacity and other harware capacities of the SCSI0 hard disk (such as the speed: 80.0Mb/s, and so on). But then there came the message:

partition check: 
sda:sda1<scsi:abort command due to timeout: pid 19, scsi0  [or something like that]

and after that, there was the same old message:

(scsi0:0:15:-1) unexpected busfree, LASTPHASE=0xa0, SEQADDR=0x167
scsi host 0 abort (pid 17) timed out - resetting

And then there were endless repetitions of resetting, just as before.

Now, I tried to boot the installer CD with no SCSI disk connected to the SCSI card. In that configuration (the SCSI card only, and the mainboard with IDE disks) the installer did proceed. Thus it means that I could probably install the SCSI card only, but without installing any SCSI devices. And as you see, this is a fatal problem if I am trying to install the operating system with some SCSI mass storages, especially if I try to install the system into a SCSI hard disk...

As I am not quite familiar with Linux, I have tried to install many different Linux distributions into my SCSI partition. I have not managed to install Linux Mandrake either, but in the Mandrake case the problem was that the installer hanged during the phase when it was time to choose the data security level. The strange thing was that even in that case I did manage to install the operating system into the IDE partition, but only if there was no SCSI card connected into the PCI slot.

In the Debian case, I manage to install the SCSI card itself (and it is to admit that that is some progress...:-), but I still do not manage to install the operating system if any kind of SCSI devide is present. How to proceed...?

Regards: Janne M. Vainio, Helsinki, Finland

Reply to: