[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Module (eepro100) won't install

On Fri, Dec 14, 2001 at 06:32:17PM -0800, Lars Jensen wrote:
> Since I have a two-processor system, I upgraded the kernel to 2-4-14smp,
> and everything worked, except the network. I guess 2.2.19-compact has
> built-in support for eepro100, but 2.4.14 doesn't. Running 2.4.12, I tried 
> insmod eepro100 and it looks like the module installs without errors, 
> but it doesn't work and lsmod gives the line
> eepro100	(unused)
> I also tried to add the line
> alias eth0 eepro100
> to my /etc/modules - that didn't work either.
> Did I miss something in the installation of the module. Do I have to
> specify an io address, and if so, how do I do that with insmod?


While I don't have an eepro100, I suspect that you can get your eepro100 
going with this:

1.  In /etc/modules, remove the line that says "alias eth0 eepro100" and
    add a line that says simply "eepro100" (without the quotes).

2.  Edit /etc/modutils/eepro100 to add a line "alias eth0 eepro100"
    (also without the quotes)

3.  Run "update-modules", which regenerates the file /etc/modules.conf
    from the files in /etc/modutils

4.  Check that your network settings for eth0 in /etc/network/interfaces
    make sense

5.  Run "ifup eth0"

I should note that steps 2 & 3 *may* not be needed.  My machine at work
(which is 'testing' upgraded from 'potato') has the "alias eth0 3c59x"
line in a seperate /etc/modutils/3c59x file.  My machine at home which
was installed from 'testing' does not.


Reply to: