[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with ppp after upgrade to kernel 2.4.X

Hi everybody!

This weekend I upgraded my server from potato to woody. Everything worked
fine. Then I upgraded my kernel from 2.2.14 to 2.4.13. And after that I run
into great problems with my ppp link. In the syslog I get sometimes "VJ
decompression error" and when I watch a the interface with "ifconfig ppp0" I
get somethin like this

ppp0 ....
		  RX packets:29 errors:16 dropped:0 overruns:0 frame:0
		  TX packets:43 errors:0 dropped:0 overruns:0 carrier:0

At last the half of the received packets have an error. Sometimes I get a
realy fine connection with no errors, but most connections are bad. And when I
switch back to the 2.2.14 kernel all runs fine again!?!?!  I tried other 2.4
kernels (2.4.0 and 2.4.1) and got the same problems.

Additional I have a hylafax server running on this modem, but it doesn't make
a difference if the server is running or not. I can submit and receive faxes
without any problem, so it seems, that the modem and the serial connection to
the modem are ok.

Could this be an incompatibility between some of my isp dial in servers and
the 2.4 kernel?

Here my hard and software configuration:

IBM thinkpad 380E
Elsa microlink office modem

german t-online isp

kernel 2.4.13
pppd 2.4.1.uus
hylafax 4.1beta2

Thanks in advance for your help!!

mfg Markus Braun

Linux is like a Wigwam. No Windows, no Gates, and an Apache inside.
Markus Braun                                    fon & fax: 07453/930851
Gartenstrasse 6                      \|/        email: Markus.Braun@krawel.de
72227 Egenhausen                    (o o)       homepage: www.krawel.de
 GnuPG Key: 0x1A5A7357 / C1CE DC19 B189 1712 419C  3944 6FA4 8F01 1A5A 7357

Reply to: