[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libexpat1 (1.95.2-2.1) broke PHP4

Thus spake Makaveli:
> I don't know exactly where to post this, so forgive if this is the wrong list.
> I did an apt-get update and apt-get upgrade today. After this my PHP4 package
> didn't work correctly anymore.
> When I run a PHP4 script on the console I got the following error:
> php4: error while loading shared libraries: libexpat.so.0: cannot open shared
> object file: No such file or directory
> The file libexpat.so.0 doesn't exist anymore. Before the upgrade to libexpat1
> (1.95.2-2.1) I had no problem with running scripts.
> After I made a symlink from libexpat.so.1 to libexpat.so.0, my scripts did work
> again. But I don't know if this is a good solution.
> FYI: I run Woody on a Pentium 60 with 16 MB ram.
> Woody was installed by a net-install about a month ago.
Same problem here, although it was AbiWord that broke for me.  Same
solution fixed it, but I have no answer for whether this is the _right_
way to fix it.

If you're going to America, bring your own food.
		-- Fran Lebowitz, "Social Studies"

Reply to: