[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

intel fortran compiler



Hi all, I downloaded the intel compiler form Intel and I want
to check it on my pentium IV computer. I run unstable with 2.4.10
kernel.

The tar file from Intel contain 5 rpm packages (for RH 6.2) and an install
script. I can't run the install script. I try to make .deb out of .rpm
using alien, but for few packages it is not working. I get this error:

computer: fortran# alien intel-efc64-5.0.1-37.ia64.rpm
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libCEPCF90.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libF90.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libIEPCF90.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libPOSF90.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libcprts.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libcprts.so.2:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libcxa.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libcxa.so.2:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libintrins.so:
File format not recognized
objdump: debian/intel-efc64/opt/intel/compiler50/ia64/lib/libunwind.so:
File format not recognized
objdump:
debian/intel-efc64/opt/intel/compiler50/ia64/lib/libunwind.so.2: File
format not recognized
dpkg-shlibdeps: warning: format of libmofl.so not recognized
dpkg-shlibdeps: warning: format of libmofl.so not recognized
dpkg-shlibdeps: warning: format of libsched.so not recognized
dpkg-shlibdeps: warning: format of libasmutils.so not recognized
dpkg-shlibdeps: warning: format of libSymDbg.so not recognized
dpkg-shlibdeps: failure: ldd on
`debian/intel-efc64/opt/intel/compiler50/ia64/lib/crtxi.o' gave error
exit status 1
dh_shlibdeps: command returned error code
make: [binary-arch] Error 1 (ignored)
dpkg-gencontrol: error: current build architecture i386 does not appear
in package's list (ia64)
dh_gencontrol: command returned error code
make: *** [binary-arch] Error 1
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
cp -a `ls -1 |grep -v debian` debian/intel-efc64
dh_installdocs
dh_installchangelogs
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol


Out of 5 .rpm I made only 3 .deb. Did someone succeeded to install
this compiler?


Thank you for your help.

Ionel

P.S. The compilers can be downloaded from
"http://developer.intel.com/software/products/eval/";
(version complete without support).



Reply to: