[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What to do next?

Hi all,

 Sorry for asking stupid questions again.
I've now compiled and installed Linux kernel 2.4.9, so the sis900.o should be working properly. What should I do next to get online? First, my /etc/modules.conf does not contain any line about the sis900 module. Should I add something like "alias eth0 sis900"? If I should, how to add such a line(The file tells me not to modify it)? Second, sis900.o is compiled as a module instead of a build-in of the kernel. So I must load the module. I've tried to load the module with modconf, but no module was found. (Probably because modules are located at /lib/modules/2.4.9/drivers/net/ instead of /lib/modules/2.4.9/net) I then tried insmod sis900, but the following error message was printed:
 Using /lib/modules/2.4.9/kernel/drivers/net/sis900.o
 RTNL: assertion failed at devinet.c(776):inetdev_event
/lib/modules/2.4.9/kernel/drivers/net/sis900.o: init_module: No such device Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
How to load it into the kernel correctly?

Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

Reply to: