[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: devfsd + xconsole

On Mon, Aug 27, 2001 at 06:45:35PM -0700, Eric G. Miller wrote:
| On Tue, Aug 28, 2001 at 01:58:18AM +0200, Eamon Roque wrote:
| > Hi!
| > 
| > Is there anything special that one has to do to get xconsole working
| > with devfs? I have the newest devfsd from unstable, but xconsole just
| > doesn't seem to want to start. I have it starting in my Xsession file
| > (/etc/X11/Xsession) and have put it in xinitrc for good measure. no
| > dice.
| > Is there any sawfish/gnome incompatibility?! Is it really devfs?! Have I
| > just not read the write documentation?!
| > 
| > I'm running unstable with kernel 2.4.8 and devfsd_1.3.18-1_i386.deb
| > 
| > Any tips?
| I have no idea if there is an issue with devfs, but are you sure
| xconsole is trying to read from the correct device?  By default, I think
| it tries to read /dev/console, but it should use /dev/xconsole (which is
| a FIFO).  "xconsole -file /dev/xconsole"  You need to have permission to
| read /dev/xconsole as well ("adduser <you> adm").

I tried it out last night (2.4.8 w/ devfs) and
    xconsole -file /dev/xconsole
works.  It didn't give me much useful information, though (not what I
expected, anyways).  I then tried 
    xconosle -file /var/log/syslog
and will keep that in my startup sequence :-).  Then I will know
immediately when something happens.


Reply to: