[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libao0, libao2: conflict, cannot dist-upgrade

  there is a problem with libao2 trying to overwrite a library that
libao0 also provides and no matter what I do it doesn't want to finish
upgrading (or install/remove any packages), here's the error message I
get when I do upgrade:

jojda:/home/erik# apt-get update && apt-get dist-upgrade   
... snipped normal messages...
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  vorbis-tools: Depends: libao2 (>= 0.8.0-1) but it is not installed
E: Unmet dependencies. Try using -f.

  when I use -f it does not help:

jojda:/home/erik# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 127  not
1 packages not fully installed or removed.
Need to get 0B/17.3kB of archives. After unpacking 135kB will be used.
Do you want to continue? [Y/n] 
(Reading database ... 99926 files and directories currently installed.)
Unpacking libao2 (from .../libao2_0.8.0-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libao2_0.8.0-1_i386.deb
 trying to overwrite `/usr/lib/ao/libalsa.so', which is also in package
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

  when I try to install or remove packages with or without -f (the
libao0/2 packages) it gives the same error. How to get out of this?



Reply to: