[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: qtcups_2.0-4

On Mon, 6 Aug 2001, john gennard wrote:
> Sorry for the delay, but I've had major problems with dependencies,
> dselect wanting to remove many of my installed packages, apt wanting
> to install stuff for kde which seem to me unnecessary. I'm still
> trying to sort out the mess! I've little experience, but it seems
> I've been 'sucked in' by so many updated packages that I've lost
> any idea of what 'qtcups' will work with what 'cups'. Also, instead
> of sticking to apt-get and dpkg and installing one or two packages
> at a time, I've tried to be too clever by getting dselect to deal with
> many - it just seemed to develop a mind of its own.

Yes, you need to be careful with these packaging tools. Still, they are
way better than anything else out there. I've never tried to use dselect.
Apt and dpkg seem quite adequate for normal use. From what I've heard,
dselect is best employed in crisis mode, like if you've got your packaging
system into a complete tangle.

I've used rpm quite a lot, both on Redhat and SuSE, and the Debian
packaging tools make rpm look quite silly. I think we're lucky to have
them. And apt is a relatively recent entry into this arena.

By the way, I agree that dependencies for the qt libs at kde.debian.net
seem quite strange. When I downloaded libqt-dev, I got a couple of kde
packages which didn't seem to have anything to do with it. (I assume this
is what you mean by "apt wanting to install stuff for kde which seem to me

> I am very grateful for all the trouble you've taken, and I think I 
> now see what to do. First I must do something about the remaining
> 33 packages dselect says it has removed (some I never had installed,
> some seem broken and some appear to be in an impossible position
> so far as re-installation is concerned).

> Then I'll start again with cups-1.1.9 and qtcups-2.0-3. (You didn't
> mention with which version of cups you were successful).

The version in testing, I think it is cupsys 1.1.4. When I last tried
1.1.9, the package refused to build. I filed a bug against it, and heard
it had been fixed, though I've not checked this out myself. 1.1.4 seems to
work fine, and I think testing stuff tends to have been a bit more
throughly checked out in general.

If you want a detailed list of the versions I have installed of packages
which qtcups depend on, I'd be happy to do so. I hope you won't be
disappointed when you finally get qtcups installed. It is nice, but when
all is said and done, it is only a front-end for cups.

Glad I could be of help.

                               Sincerely, Faheem Mitha.

Reply to: