[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: qtcups_2.0-4

On Sat, Aug 04, 2001 at 01:31:22PM -0400, Faheem Mitha wrote:
> > > > [snipped]
> > 
> > I managed to compile qtcups 2.0-3 (from woody) on potato without any
> > problems. I installed it and it seems to be behaving normally. My
> > immediate reaction is that there is something wrong with the version of
> > qtcups in unstable. Suggestion: try to compile the version of qtcups in
> > woody and see how it goes. Packages in unstable are often buggy and are
> > generally best avoided. For example, I could not even build the cups in
> > unstable, though the cups in testing compiled with no problem (and this
> > definitely was not a dependencies issue). If you find the version of
> > qtcups in testing builds with no problem I suggest filing a bug report
> > against the version in unstable.
> I spoke too soon. I tried compiling 2.0.4 and it compiled with no
> problem.
> > If this still does not work, note that I used versions of qt from
> > debian.kde.net ie
> > 
> > ii  libqt-dev      2.3.0-final-0. Qt GUI development headers, static 
> > libraries
> > 
> > ii  libqt2         2.3.0-final-0. Qt GUI Library (runtime version).
> > 
> > Put deb http://kde.debian.net potato main crypto optional in sources.list,
> > refresh, and try getting libqt-dev. But I doubt this is the problem.
> This seems like the only thing left to point the finger at. If you upgrade
> libqt-dev, you might as well upgrade libqt2 for good measure, even if it
> doesn't do so automatically, just to make sure. Then try again. If it does
> not work this time, I don't know what is going on.
> Note that apt might insist that you download bits of kde along with the qt
> libs. This happened to me, though I don't see why.
>                                Sincerely, Faheem Mitha.

Sorry for the delay, but I've had major problems with dependencies,
dselect wanting to remove many of my installed packages, apt wanting
to install stuff for kde which seem to me unnecessary. I'm still
trying to sort out the mess! I've little experience, but it seems
I've been 'sucked in' by so many updated packages that I've lost
any idea of what 'qtcups' will work with what 'cups'. Also, instead
of sticking to apt-get and dpkg and installing one or two packages
at a time, I've tried to be too clever by getting dselect to deal with
many - it just seemed to develop a mind of its own.

I am very grateful for all the trouble you've taken, and I think I 
now see what to do. First I must do something about the remaining
33 packages dselect says it has removed (some I never had installed,
some seem broken and some appear to be in an impossible position
so far as re-installation is concerned).

Then I'll start again with cups-1.1.9 and qtcups-2.0-3. (You didn't
mention with which version of cups you were successful).

Many thanks,               John.  

Reply to: