[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Questions about XFree86 4.x

On Thu, Aug 02, 2001 at 11:42:48AM -0400, Aaron Traas wrote:
> I'm running Woody and Xfree86 4.03 on a couple systems, and have a
> couple minor problems. Some questions on how to do a few things:
> 1) I installed a bunch of font packages in Woody, but X does not load
> them by default. I found them in /usr/X11R6/lib/X11/fonts, and proceeded
> to add them via 'xset fp+' and 'xset fp rehash'. Though this worked, I
> find myself having to do this with each X login session. Is there any
> way to tell X, globally, to always load them?

In /etc/X11/XF86Config-4 there is a section like this:

Section "Files"
        FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"

Just add another FontPath entry to point to your new directory:

	FontPath	"/usr/X11R6/lib/X11/fonts"

Don't forget to restart your X server after you've made the change.
You can check if XFree86 accepted the change by looking in
/var/log/XFree86.0.log (assuming you only have one screen).  There
should be something like

(**) FontPath set to "[...] /usr/X11R6/lib/X11/fonts"

in there.

> 2) Speaking of fonts, I can't get AA fonts working under KDE. Is there a
> package I need to install? Is it related to the following error I get
> when I run most KDE apps from the console:
> 	Xlib:  extension "RENDER" missing on display "localhost:0.0".
> 	_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root

I'll leave the AA question to someone else, since I haven't tried it.  I can
tell you about the two error messages.  The first is because you have an X
server without RENDER support.  I have the same problem with the S3 savage
module.  I don't know if AA needs RENDER support; it wouldn't suprise me if
it did.  What graphics card do you have?

You can clear the second message by doing as root:

	chown root:root /tmp/.ICE-unix

> 4) in my /etc/profile, I add the line:
> 	alias ls='ls --color -F'
> This works very nicely at the console, but for some reason, when I'm in
> X, this doesn't work in Konsole or Xterm. I have to do an:
>  	exec bash --login
> Each time I open up a terminal to get this working correctly. This also
> happens when I use 'su'. Is there any way to guarentee consistent
> behavior despite login method??

My guess would be to get the alias command executed when your X session
starts up.  You should be able to do that by adding the alias command to
~/.xsession. You may need to create it:

	echo "alias ls='ls --color -F'" >> ~/.xsession

Hope that helps,

Reply to: