[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Questions about XFree86 4.x

I'm running Woody and Xfree86 4.03 on a couple systems, and have a
couple minor problems. Some questions on how to do a few things:

1) I installed a bunch of font packages in Woody, but X does not load
them by default. I found them in /usr/X11R6/lib/X11/fonts, and proceeded
to add them via 'xset fp+' and 'xset fp rehash'. Though this worked, I
find myself having to do this with each X login session. Is there any
way to tell X, globally, to always load them?

2) Speaking of fonts, I can't get AA fonts working under KDE. Is there a
package I need to install? Is it related to the following error I get
when I run most KDE apps from the console:

	Xlib:  extension "RENDER" missing on display "localhost:0.0".
	_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root

3) When I start emacs, using my trusty old .emacs file I've been keeping
and maintaining for years, The colors I've selected aren't quite working
right. Basically, I set the background color to black, and that works,
except or where there's text. Each character taken up by something other
than whitespace has a white background. I've determined it's something
to do with X, as the same .emacs file works beautifully when I export
the display to my Solaris box. 

4) in my /etc/profile, I add the line:
	alias ls='ls --color -F'
This works very nicely at the console, but for some reason, when I'm in
X, this doesn't work in Konsole or Xterm. I have to do an:
 	exec bash --login
Each time I open up a terminal to get this working correctly. This also
happens when I use 'su'. Is there any way to guarentee consistent
behavior despite login method??

Reply to: