[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: qtcups_2.0-4

On Fri, 3 Aug 2001, john gennard wrote:

> I run Potato 2.2 r3 on a PC with a 2.2.18 kernel, and have
> tried to install the above using 'apt-get source -b qtcups' ( I 
> have a 'deb-src http' in my sources.list). This failed, ending with 
> the following error message:-

The obvious question is, have you satisfied the dependencies? When you do
apt-get source qtcupps, you will get a list of dependencies in

These are (for 2.0-3)

debhelper (>> 2.0.0), libcupsys2-dev, libjpeg62-dev, libqt-dev, xlibs-dev

Of these, debhelper 2 is bound to be installed on a potato system,
libcupsys2-dev should be installed if you have a recent version of cups
installed (and if you don't qtcups is not going to work anyway),
libjpeg62-dev is available in potato.

Unfortunately, libqt-dev is likely to cause trouble, since it doesn't
exist in potato. I think that is what I stubbed my toes on. (I tried to
compile qtcups myself on potato and finally gave up).

Unfortunately, libqt-dev is not easy to compile from source either, and it
has so many dependencies you will end up dragging in significant parts of
woody to your potato installation if you just try to fetch the package
from woody.

Note that you need qt libs of at least 2.2 for this.

My error message for this says

checking for Qt... configure: error: Qt (>= Qt 2.2.1) (headers and
libraries) not found. Please check your installation!

I guess this is not very helpful. Perhaps somebody else can suggest

                        Sincerely, Faheem Mitha.

Reply to: