[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pci faxmodem device file

uhlhorsr <stephen.uhlhorn@vanderbilt.edu> writes:

> lspci -vv gives:
> 02:0a.0 Serial controller: US Robotics/3Com 56K FaxModem Model 5610 (rev 01) 
> (prog-if 02 [16550])
> 	Subsystem: US Robotics/3Com: Unknown device 00d7
> 	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- 
> SERR+ FastB2B-
> 	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- 
> <MAbort- >SERR- <PERR-
> 	Interrupt: pin A routed to IRQ 11
> 	Region 0: I/O ports at dff0 [size=8]
> 	Capabilities: [dc] Power Management version 2
> 		Flags: PMEClk- AuxPwr- DSI- D1- D2+ PME+
> 		Status: D0 PME-Enable- DSel=0 DScale=2 PME-
> and dmesg gives:
> Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI 
> enabled
> ttyS00 at 0x03f8 (irq = 4) is a 16550A
> PCI: Found IRQ 11 for device 02:0a.0
> Redundant entry in serial pci_table.  Please send the output of
> lspci -vv, this message (4793,4104,4793,215)
> and the manufacturer and name of serial board or modem board
> to serial-pci-info@lists.sourceforge.net.
> ttyS04 at port 0xdff0 (irq = 11) is a 16550A
> It appears the kernel is giving the modem /dev/ttyS04, but I have no device 
> files /dev/ttySXX. My serial devices are ttyS[0-3] (1 digit only, not 2). I 
> tried using setserial to assign the irq, and i/o to ttyS1, but setserial said 
> the recources were in use.

Hi!  I just went through this myself a few weeks ago with the exact same
modem.  I found, actually, you can do this two ways.  Even though it says
differently in the instructions that came with the modem, you can get the
modem working with the 2.2.x series kernels.  (using the method you tried
with setserial) It works perfectly that way.  But, since you already have the
2.4.x kernel, then all you have to do is create a new ttySX device and run
the setserial on that.  (I had the same problem after upgrading the kernel in
that it wouldn't allow me to use the ttyS* devices already there.  I never
did figure that one out).  So, just:

cd /dev
MAKEDEV ttyS4       (yes, MAKEDEV has to be in caps)
setserial /dev/ttyS4 uart 16550A port 0xdff0 irq 11

Then just point your ppp configuration (whether you use pon or wvdial or
whatever) to the /dev/ttyS4 device file, and *poof* you should be online!  If
it works, then all you have to do is add the setserial line (minus the actual
"setserial" command) in your /etc/serial.conf file, and then it's configured
for you each time you boot.

Truthfully, as far as the system saying that it's assigned to ttyS04, I don't
know why it says that and then the file's not in /dev.  If someone knows why
and can show either of us how to use this to our advantage in setting up the
modem, I'd love to hear it.  

Good luck!


Reply to: