[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrade help

On Wed, Aug 01, 2001 at 09:19:19PM -0400, Robert Schweikert wrote:
> Hi,
> hen I try to upgrade my distribution from potato to woody I get the
> following error.
> 97% [Scanning packages]Template parse error near "" at
> /usr/lib/perl5/Debian/DebConf/Template.pm line 60, <TEMPLATES> chunk 3.
> E: Sub-process /usr/sbin/dpkg-preconfigure --apt returned an error code
> (29)
> E: Failure running script /usr/sbin/dpkg-preconfigure --apt
> Unfortunately I know nothing about Perl. I expect that more information
> is needed, but I don't know what this information would be.
> The steps I took
> apt-get update (This fetched the files for stable and testing)
> apt-get upgrade (this upgraded the current distribution, this worked)
> apt-get dist-upgrade (this failed)
> Thanks for any help.
> Robert
> --
> Robert Schweikert                      MAY THE SOURCE BE WITH YOU
> rjschwei@mindspring.com                         LINUX

I ran into a similar problem with Templates.pm doing this upgrade
earlier this week.  I found a suggestion in the list archive that
got me past it - upgrade debconf to the Woody/testing version first
(0.9.81).  Then try your apt-get dist-upgrade again.


Larry Holish

Reply to: