[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Testing upgrade: Potentially harmful(?) problem



On Fri, Jul 13, 2001 at 09:56:03PM -0400, Sebastian Canagaratna wrote:
> 
> Hi (Jim and D):
> 
> Some further notes. The dist-upgrade seems to get stuck trying
> to install libc6-dev2.2.3-5 ( it seems to think that
> this depends on libc62.2.1 ) but this is not available in testing:
> 
> trying to overwrite /usr/bin/rpcgen which is also in package netbase
> dpkg-deb: subprocess paste killed by signal(broken-pipe)
> 
> Trying  dpkg -i libc6-dev2.2.3-5 also gives the same error.
> 
> So even if I try apt-get install debconf perl5.004 etc, it gets stuck
> at the libc6dev.
> 
> (My other machine, which incidentally is unstable not testing as I
> stated earlier had trouble with debconf but I was able to manually
> install debconf and seems to be chugging away as I write, installing
> the packages)
> 
> I can of course try to go to unstable, but I would rather not right
> now. What other routes are available
> 
> Thanks
> 
> Sebastian.




	Hi There Sebastian,

	I got something you can try. Go to you're /etc/apt/apt.conf.d dir
directory and then edit the file named 70debconf. Add the following
lines below the line that's already there. The line that's already there
is what I will list here first, followed by the additions I want you to
make. You can just copy and paste them from this e-mail if you want.



DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};
{
  Options {"--force-overwrite,depends";}
};  
  
Use you favorite editor to add those three lines(the middle one being
the main gist of the thing) and you should be good to go. Really, first
you should back up the orginal with something like so...

cp 70debconf 70debconf.orig

Then when you are done you can restore 70debconf to it's original form.
This cause apt-get to act like   dpkg --force-overwrite --force-depends.



	Good Luck and let me know how it goes!

	Jimmy Richards

He that is slow to believe anything and everything is of great
understanding, for belief in one false principle is the
beginning of all unwisdom.

	-- Mahatma Ghandi





> On Fri, Jul 13, 2001 at 07:11:45PM -0400, D-Man wrote:
> > On Fri, Jul 13, 2001 at 06:49:43PM -0400, Sebastian Canagaratna wrote:
> > | Hi:
> > | 
> > |  I am trying to upgrade testing on my second machine (apt-get
> > |  update; apt-get dist-upgrade) but it aborts. So I first tried to
> > |  install debconf ( apt-get install debconf ) and I get:
> > | 
> > |  Extra Packages to be installed:
> > |     libhtml-parser-perl  libhtml-target-perl  libmime-base64-perl
> > |     libperl5.6  perl  perl-5.004  perl-5.004-suid  perl5.6
> > |     perl-base perl-modules.
> > | 
> > |  Removed: perl-5.004-base
> > |           perl-5.005
> > | 	  perl-5.005-base
> > | 
> > | New: libhtml-tagset-perl
> > |      libperl5.6
> > |      perl
> > |      perl-modules
> > |      perl-suid
> > | 
> > | Essential package to be removed: perl-5.004-base. You are about to do
> > | something potentially harmful. Don't do this unless you know what you
> > | are doing.
> > | 
> > | At this stage I aborted.  Anybody have any ideas whether its Ok
> > | to say yes?
> > 
> > The perl version changed.  However, perl is a critical component of
> > the Debian core (dpkg or apt or debconf or something like that).  If
> > you do a dist-upgrade then everything will get upgraded together and
> > there won't be a problem because you replace one perl with another,
> > and all the packages that depend on it are replaced with packages that
> > depend on the new perl instead.
> > 
> > I did a dist-upgrade a few weeks ago without any trouble.  Maybe if
> > you try again, as opposed to upgrading stuff one-at-a-time it will
> > work better?  Why did it abort in the first place?  Did dpkg just die?
> > If so, run it again (it happened to me a couple times).
> > 
> > At the moment I have :
> > 
> > $ dpkg -l perl\*base
> > Desired=Unknown/Install/Remove/Purge/Hold
> > | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
> > |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err:
> > |uppercase=bad)
> > ||/ Name           Version        Description
> > +++-==============-==============-============================================
> > pn  perl-5.004-bas <none>         (no description available)
> > ii  perl-5.005-bas 6.2            Transitional package.
> > un  perl-5.6-base  <none>         (no description available)
> > ii  perl-base      5.6.1-5        The Pathologically Eclectic Rubbish Lister.
> > un  perl5-base     <none>         (no description available)
> > 
> > 
> > -D
> > 
> > 
> 
> Sebastian Canagaratna
> Department of Chemistry
> Ohio Northern University
> s-canagaratna@onu.edu
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Attachment: binTSe6kS_wSD.bin
Description: PGP Key 0x0062D7A7.

Attachment: pgp7NMJfvWzp6.pgp
Description: PGP signature


Reply to: