[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: setting up cvs server: connection refused SOLVED



On Thu, Jul 12, 2001 at 12:34:42AM -0500, will trillich wrote:
[snip]
> > My understanding is, you probably want to be using ssh and :ext: method
> > rather than the ":pserver:" method for read/write repositories.  But, I
> > guess, that configuration is a little different.
> 
> but from what i've read, you gotta "cvs -d :pserver:.... login"
> first, THEN you can "cvs -d :ext:.... whatever" later.

Not if you use authentication keys on both ends via ssh (or ~/.rhosts --
bad idea).  I've been participating in a project for several months now
where I supplied the CVS admin a public key and I have a shell script
that sets up my CVS environment (doing CVS_RSH=ssh, CVSROOT="...", and
doing "eval `ssh-agent`; ssh-add"  to set up ssh authentication for the
current terminal.  I don't have anything to do with the server, but
they're also filtering on IP address(es).  I never have to issue the
login directive (just my passphrase when I run the shell script,
ssh-agent handles the rest).  But, I really don't know much about
administering CVS (I just use directory under $HOME for my personal
projects...).

> but when it said 'connection refused' it meant it, since i was
> trying to connect on my external ip, but i'd told xinetd.conf to
> bind pserver listenings to 192.168.1.1 -- DUH.
> 
> i'm feeling MUCH better now.

Ahh.

-- 
Eric G. Miller <egm2@jps.net>



Reply to: