[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrade loop error

On Fri, Jul 06, 2001 at 10:42:09AM -0500, destruss@iowatelecom.net wrote:
> Hi all:
>  Did an apt-get dist-upgrade using testing and at the end had an 
> error of:
> 'errors were encountered while processing:
> /var/cache/apt/archives/libstdc++2.10-dev_1%3a2.95.4-                  
>                                   0.010424_i386.deb
> /var/cache/apt/archives/libc6-dev_2.2.3-5_i386.deb
> E: subprocess /usr/bin/dpkg returned an error code (1)'

You did not show the actual errors.

If it was a failed download,  just re-run apt-get, it tries again.

> I then tried to use dpkg to install the first deb, and received:
> 'Unable to install
> package requires libc6 which needs to be configured'
> so I did a dpkg configure for libc6 and received:
> 'Unable to configure
> package requires libdb2'
> so I did a dpkg configure for libdb2 and received:
> 'Unable to configure
> package requires libc6'
> I thought someone had just answered this and went to geocrawler
> but I must have missed the answer. Sorry.               Dean

Maybe it will find this one:

  dpkg -iGOEB /var/cache/apt/archives/{libdb2,libc6,libstdc++}*deb 

But ideally, you should not have to use dpkg on packages in apt's
download cache.  Try using the appropriate high level tools where
available.  Use dselect.



Reply to: