[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Going slightly spare!

I'm trying to compile a driver from scyld.com on my Debian 2.2r3 install.  I
have the kernel source downloaded from kernel.org (as this isn't for my Debian
install - I have also tried the sources from Debian with now luck), but when I
compile I get the error:

linux/modversions.h: No such file or directory

I have trawled the archives and found references to needing the kernel headers,
and running make oldconfig to get the file created, but although I now have the
file I still get the error.  It is located in linux/include/config/ not just in
linux/, but even if I copy the file there I have no joy.

I have checked the permissions, and tried compiling as root, but still with no
luck.  I've also seen the comment about compiling with the '-DMODVERSIONS'
flag, but since I'm not compiling with it that doesn't help either.

Can anyone give me any pointers?  In my last job I did this fine on the RedHat
6.2 install I inherited, but since I don't know the history of that install,
and to have access to the machine any more I can't use that to assist me :-(
I'm working with both the 2.2.18 and 2.2.19 sources btw.

Paul Tansom:    Talking to penguins can be inTUXicating, whereas
talking to windows is only 1 step away from talking to the wall!
Smoothwall firewall/router project: http://www.smoothwall.org/
Smoothwall project community contact: community@smoothwall.org

Reply to: