[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Printer help please!

For the last three days I have been banging my head against the wall 
("don't worry dear, its as pointy as ever it was" says my sympathetic
girlfriend) trying to get my printer to work. I installed potato some 
time ago and tried to install cups, but didn't have much luck, so
I stripped everything off and re-installed lprng. I then used apsfilter 
to configure things, the apsfilter printed a perfect test page but
when I used lpr....nothing! I tried with printtool which printed a 
test ascii direct to the port but under lpr the printer muttered a
bit and then stopped. lpq -L gives me the following

	bernard@debian:~$ lpq -L
	Printer: lp@debian 
	 Queue: no printable jobs in queue
	 Status: accounting at start at 14:35:56.401
	 Status: opening device '/dev/lp0' at 14:35:56.452
	 Status: printing job 'root@debian+779' at 14:35:56.468
	 Status: printing 'root@debian+779' starting OF at 14:35:56.468
	 Status: printing data file 'dfA779debian', size 42 at 14:35:56.468
	 Status: IF filter finished at 14:35:57.631
	 Status: printing done 'root@debian+779' at 14:35:57.631
	 Status: accounting at end at 14:35:57.631
	 Status: finished 'root@debian+779', status 'JSUCC' at 14:35:57.631
	 Status: subserver pid 5782 exit status 'JSUCC' at 14:35:57.636
	 Status: lp@debian: job 'root@debian+779' printed at 14:35:57.637
	 Status: job 'root@debian+779' removed at 14:35:57.639

I can't see much wrong with the permissions-I'm currently operating 

	bernard@debian:~$ ls -l /var/spool/lpd
	total 24
	drwx------    2 daemon   lp           4096 Jul  2 14:53 lp
	drwxr-xr-x    2 lp       lp           4096 Jul  2 11:54 stcolor-a4-ascii-color

	debian:/home/bernard# ls -l /var/spool/lpd/lp
	total 28
	-rw-------    1 daemon   lp           1602 Jul  2 14:53 acct
	-rw-------    1 daemon   lp              0 Jul  2 13:56 control.lp
	lrwxrwxrwx    1 root     lp             35 Jul  2 13:56 filter -> /usr/share/printtool//master-filter
	-rw-------    1 daemon   lp            187 Jul  2 13:56 general.cfg
	-rw-------    1 daemon   lp              0 Jul  2 13:56 log
	-rw-------    1 daemon   lp              5 Jul  2 14:53 lp
	-rw-------    1 daemon   lp            346 Jul  2 13:56 postscript.cfg
	-rw-------    1 daemon   lp              0 Jul  2 13:56 status
	-rw-------    1 daemon   lp           2847 Jul  2 14:53 status.lp
	-rw-------    1 daemon   lp            146 Jul  2 13:56 textonly.cfg
	-rw-------    1 daemon   lp      

I would be pathetically crawlingly grateful to anybody who could assist. There is 
absolutely no shortage of additional information-three days worth-if required.

Bernard Pack


"I have a perfectly stable system, as in,'we've cut him from
the wreck and given him four pints of blood and his condition
is stable'"

Reply to: