[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

testing upgrade stallout



Hi,

I ran what proved to be a rather large apt-get dist-upgrade last week, and
wound up with some dependency conflicts which I don't know how to get
around/rid of. The packages downloaded did not finish installing, and when
I try to run apt-get dist-upgrade NOW what I get is the following:

Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  php3-pgsql: Depends: libpgsql2.1 (>= 7.0.3-3) but it is not installed
              Depends: php3 (= 3:3.0.18-12) but 3:3.0.18-0potato1 is installed
  postgresql: Depends: libpgsql2.1 (>= 7.1) but it is not installed
              Depends: libpgsql2.1 but it is not installed
  postgresql-client: Depends: libpgsql2.1 (>= 7.1) but it is not installed
                     Depends: libpgsql2.1 (>= 7.1) but it is not installed


Unfortunately, running 'apt-get -f install' doesn't seem to fix the
problem.

I believe another user posted this problem recently; however, I seem to
have lost any useful reply to that message, and can't seem to find it in
the list archives. Where should I begin getting around this?

Thanks for any hints.

Best,

Glenn Becker

+----------------+
http://www.burningclown.com
"Everyone's Portal to Nothing At All"
+----------------+



Reply to: