[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [xine-user] subpictures

Rich Wareham wrote:

Are you compiling from source or using the Debian package? If the latter
then it may be a problem with the package. If the former then try changin
to the xine directory and running:

make distclean
../configure --prefix=/usr/local
and as root

make install

Thies will re-configure Xine and re-install it because at the moment Xine
seems not to be able to find the correct 'plugin' for it to work properly.

Also make sure that the directory it is looking for (in this case
/usr/lib/xine/plugins) is in the file /etc/ld.so.conf

Hope that helps


On Wed, 4 Apr 2001, eric wrote:

Rich Wareham wrote:

On Tue, 3 Apr 2001, eric wrote:

Rich Wareham wrote:

Dear Rich:

  Do you know what may cause demuxers not found error when I run xine?

What sort of file are you trying to play? Are you trying to play a DVD? If
so look at http://xine.cjb.net/ for a suitable CSS plugin.

It would also help if you could send a copy of the error message Xine
prints out.


Dear Rich:

  I tried to reinstall libcss and xine_dvd_libcss_plugin and ldconfig
but it still not work

the following is error message I got:

This is xine - a mpeg 1, 2 player v0.4.0 - (c) 2000 by G. Bartsch.
Allocating 2000 buffers of 4096 bytes in one chunk (alignment = 2048)
No extra demux plugins found in /usr/lib/xine/plugins
xine_init: demuxer initialized
video_out_xv: no video port found

WARNING: current display depth is 24. For better performance
a depth of 16 bpp is recommended!

Using X Window System shared memory extension for video output.
yuv2rgb: 32 bpp, mode : 1
yuv2rgb: using MMX for colorspace transform
Using MMX for IDCT transform
Using 3DNOW for motion compensation
xine_init: video thread created
xine_init: SPU thread created
audio driver '(null)' init failed - no audio.
xine_init: audio thread created
input plugin found : /usr/lib/xine/plugins/input_stdin_fifo.so(input_stdin_fifo.
input plugin found : /usr/lib/xine/plugins/input_dvd.so(input_dvd.so)
input plugin found : /usr/lib/xine/plugins/input_file.so(input_file.so)
input plugin found : /usr/lib/xine/plugins/input_net.so(input_net.so)
input plugin found : /usr/lib/xine/plugins/input_vcd.so(input_vcd.so)
xine_init: plugins loaded
error: couldn't find demuxer for >DROP A FILE ON XINE<

I am using 2.4.2 debian

hope to see your help again soon

Dear Rich or any xine experts :

I finally make my 2.4.2-k7 both can cdrecord -scanbus also can access regular iso9660 cd or listen music cd,
I also tried what you suggest above, but xine is not playing my dvd,
I also tried to copy some vob file(dvd movies) , run xine some.vob, but it still not playing
I also run hdparm /dev/hda(my dvd device locate)

lshih:~/xine_dvd_libcss_plugin# hdparm  /dev/hda

HDIO_GET_MULTCOUNT failed: Invalid argument
I/O support  =  1 (32-bit)
unmaskirq    =  1 (on)
using_dma    =  1 (on)
keepsettings =  0 (off)
HDIO_GET_NOWERR failed: Invalid argument
readonly     =  1 (on)
readahead    =  8 (on)
HDIO_GETGEO failed: Invalid argument

is that good enough to play dvd on my platform?

hope to see your tech help and thanks in advance

Reply to: