[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(partly solved)Re: what is 'slot-service-0-3' ?

THANKS to everyone to replied to my question!

I got it partly solved - I can now play music from the CD player.
I found out that my sound card can emulate a sound blaster and after recompiling the kernel w/o pnp-support I now listen to CD's.
Playing mp3's is still not working.
Here's what I have in my BIOS:

WSS I/O Address =530H
SBPro I/O Address = 220H
Synth. I/O Address = 388H
WSS & SBPro & MPU401 IRQ Level IRQ=7
WSS (Play) DMA Channel  =1
WSS (Rec.) & SBPro DMA Channel  =2
Control I/O Address  =538H
MPU401 (MIDI I/F)  =330H

when I try to load the sound blaster module I can play music CD's ....

modprobe sb io=0x220 irq=7 dma=1 dma16=5 mpu_io=0x330
kernel: Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
kernel: SB 3.01 detected OK (220)
kernel: SB DSP version is just 3.01 which means that your card is
kernel: several years old (8 bit only device) or alternatively the sound driver
kernel: is incorrectly configured.
kernel: Sound: DMA (output) timed out - IRQ/DRQ config error?

When I try to load the OPL3-SA2 modules I can't do anything - not even playing CD's:

insmod opl3sa2 irq=7 dma=1 dma2=0 io=0x538 mpu_io=0x330 mss_io=0x530
Using /lib/modules/2.4.2/kernel/drivers/sound/opl3sa2.o
/lib/modules/2.4.2/kernel/drivers/sound/opl3sa2.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters

and /var/log/syslog says:
kernel: opl3sa2: Control I/O port 0x0 not free

These are all the parameters that are set in my BIOS and which just fine with the 'old' kernel.

Any ideas??

Reply to: