[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrade badly broken-XFree86

> I just rendered my system basically unusable doing an apt-get dist-upgrade.
> I was aiming for woody; my system was potato + bits of woody.  The problem 
> seems to be with XFree86; I was on 3.3.
> I had debug logging enabled on apt-get, so I can provide gory details.  But 
> here are the highlights:

> Preparing to replace xbase-clients 3.3.6-11potato15 (using 
> .../xbase-clients_4.0.2-1_i386.deb) ...
> Note: Removing obsolete /usr/X11R6/lib/X11/xinit directory.
> Unpacking replacement xbase-clients ...
> D000400: does_replace ... found old, version 0:
> dpkg: error processing /usr/var/apt/archives/xbase-clients_4.0.2-1_i386.deb 
> (--unpack):
>   trying to overwrite `/usr/X11R6/bin/xf86config', which is also in package 
> xserver-common
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Subsequent attempt to apt-get -f install or apt-get remove various packages 
> fail because of dependency problems.
> Any suggestions how to proceed?  And should I report this as a bug against 
> apt-get, xfree, none, both?

I don't know which package to report against, but you could do 

$> dpkg --force-overwrite --install xbase-clients

That should fix that problem, then do a $> dpkg -a --configure to fix the 
pending stuff.

Lance Levsen, Programmer
Product Innovation
PWGroup - S'toon.

Reply to: