[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unstable broken upgrade



On Sat, Feb 03, 2001 at 06:15:23AM -0500, Anthony Fox wrote:
> Hi,
> 
> I have an unstable debian box at home.  When doing the last apt-get
> update; apt-get dist-upgrade, I get the following errors:

[lots of cruft clipped]

> (Reading database ... dpkg: error processing
> /var/cache/apt/archives/ae_962-28_i386.deb (--unpack):
>  files list file for package `bonobo' is missing final newline

And here we have the actual error. You might have experienced minor file
corruption, similar things have happened to me too. Quick fix is to edit a
file in /var/lib/dpkg/info/, in this case bonobo.list and to make sure
that the last line ends with a newline.


> How do I get around these errors so that I can continue to upgrade
> my box regularily?

After fixing the file you should be able to continue the upgrade. Just to
be on the safe side, you should reinstall bonobo to get the dpkg database
properly consistent.


-- 
Tommi Komulainen                                 Tommi.Komulainen@iki.fi
GPG 1024D/68388EE6    6FD6 DD79 EB38 BF6F 3533  09C0 04A8 9871 6838 8EE6

Attachment: pgp8AzaPVDivU.pgp
Description: PGP signature


Reply to: