[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help needed on first install

Hi Rick,

COM1: maps to ttyS0 not tty0.

To tell X where to look for your mouse:
Make sure your 'Device' in the 'Pointer' section of /etc/X11/XF86Config is set to "/dev/ttyS0"

If you still have problems try checking for gpm running as this can cause problems with X. If it is stop it (as root use: /etc/init.d/gpm stop ) then try starting X. gpm is there to provide support for a mouse when you are in console mode, so you may not need it.
If X works without gpm try starting gpm with the -R option (see man page).

'ps ax | grep gpm' gives the following for me (Logitech 3-button using IntelliMouse protocol):

/usr/sbin/gpm -m /dev/psaux -t ps2 -Rms3


Rick Commo wrote:

This is my first ever Debian install.  Previous experience limited to RH
4/5 years ago and recently Mandrake 7.1, so I am not a heavy Linux type at
this point.

    Old AT style mainboard with 233Mhz Cyrix 8x86
    80Mb Ram
    Microsoft mouse (also Kensington trackball)
    ATI Expert98 graphics card

    Debian 2.2r2 (potato)

    I managed to muddle my way into getting the system to boot into the
GUI mode and display
    at 1024x768, but the mouse doesn't work.

    I have tried both the Microsoft mouse and Kensington trackball.  Since
it's an older AT style
    mainboard the mouse goes on COM1 (using WinSpeak).  I figured this
would be /dev/tty0.
    Have tried all the different baud rates.  NADA

A couple of questions

(1) any hints?

(2) I have managed to log into root in the GUI but can't seem to bring up
an xterm with no mouse available.  What would be the key strokes to do
that (if at all possible).






Reply to: