[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dependency problem

I have a mostly potato system with a few newer packages installed.  In
particular I have installed newer ALSA packages including 
libesd-alsa0_0.2.22-3.  The control info for this package indicates that
it "Provides: libesd0".  Now when I run "apt-get upgrade" I get the
following error messages:
   Sorry, but the following packages have unmet dependencies:
     gedit: Depends: libesd0 (>= 0.2.14-0.2)
     gtop: Depends: libesd0 (>= 0.2.14-0.2)
   E: Unmet dependencies. Try using -f.

apt-get -f upgrade - wants to remove gedit and gtop.

Why doesn't libesd-alsa0 meet this dependency?  Does it need version info
in the Provides line?

Both gtop and gedit run and even emit an occasional annoying noise.  How
can I make apt-get happy?


Reply to: