Re: dependency problem
I need to remember to check the bug reports before asking questions like
this. There is a information about this in the gedit bug reports.
I have not done this yet, but it looks like the solution is to recompile
gedit, gtop using my new libesd-alsa0.
On Fri, Feb 02, 2001 at 09:26:50PM -0500, John Kuhn wrote:
> I have a mostly potato system with a few newer packages installed. In
> particular I have installed newer ALSA packages including
> libesd-alsa0_0.2.22-3. The control info for this package indicates that
> it "Provides: libesd0". Now when I run "apt-get upgrade" I get the
> following error messages:
> Sorry, but the following packages have unmet dependencies:
> gedit: Depends: libesd0 (>= 0.2.14-0.2)
> gtop: Depends: libesd0 (>= 0.2.14-0.2)
> E: Unmet dependencies. Try using -f.
> apt-get -f upgrade - wants to remove gedit and gtop.
> Why doesn't libesd-alsa0 meet this dependency? Does it need version info
> in the Provides line?
> Both gtop and gedit run and even emit an occasional annoying noise. How
> can I make apt-get happy?
> To UNSUBSCRIBE, email to firstname.lastname@example.org
> with a subject of "unsubscribe". Trouble? Contact email@example.com