[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No libforms0.89 -> no Lyx

On Thu, 1 Feb 2001, Glen Snyder wrote:

> Thanks to Mike for the tip that got the X4 upgrade in testing working
> for me. I'm a happy camper again.
> I also noticed that Lyx was removed during a recent upgrade in
> "testing". I tried to reinstall it but found that it requires
> libforms0.89  Since Lyx is (in my opinion) one of the best document
> editors around, I was wondering if anyone else had worked around this
> problem. libforms0.89-bin and libforms0.89-dev are both listed in the
> online list of packages, but just plain libforms0.89  is missing. I
> cannot apt-get install any of the 3. Suggestions?
> Thanks in advance
> Glen

I worked around this problem as follows: I downloaded the source for the
debian libforms0.89 packages and built a new package. The problem is that
libforms explicitly requires xpm4g which has been subsumed into the
xfree86 packages. I had to remove the dependency in the debian/control
file and then rebuild the packages. At that point, I could reinstall
libforms. However, I use LyX quite a bit, and I wanted the latest stable
version which is 1.1.6fix1 as of today. So, I used deb-make to debianize
the latest LyX and installed that as well. Thus, I am not sure if
rebuilding libforms will solve all the dependency problems for LyX. BTW,
I'm sure this problem will be fixed within a couple days. Now that you
have reminded me, I'll write to the libforms maintainer and/or the LyX

Thanks. Syrus.


Syrus C Nemat-Nasser, PhD    |  Center of Excellence for Advanced Materials
UCSD Department of Physics   |  UCSD Department of Mechanical
                             |    and Aerospace Engineering
     email: syrus@ucsd.edu <---> FAX: (208) 567-3114 {Idaho via efax}  

Reply to: