[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems installing Win4Lin

On Thu, Feb 01, 2001 at 08:03:49PM +0000, Adam J Beavan wrote:
> Hi
> Trying to install a downloaded evaluation copy of Win4Lin
> on my debian system version 2.2.17...
> The script install-win4lin.sh runs through OK until it needs
> to install the rpm package Win4Lin-5.1.0ga-1.i386.rpm...
> I get the following error....
> 	from rpm -i Win4Lin-5.1.0ga-1.i386.rpm
> 	error: failed dependencies:
>         /bin/sh   is needed by Win4Lin-5.1.0ga-1
> Have tried using alien which builds a debian package which I
> can subsequently install, but it is not complete because
> /etc/defaults/merge has not been created and this cause the
> install to fail...
> Any help on this one would be great!!!!
> Thanks
> adam

This was answered some time ago on one of the Win4Lin mailing lists;
if you run W4L you should consider subscribing to one or more of
these.  Unfortunately, at the present, Netraverse has dropped direct
support for Debian :(.  Fortunately it's not too difficult to install
it anyway :).  So here are the steps that worked for me (some of these
you may have done already):

1.  Download the .rpm Win4Lin-
2.  Convert to .deb:  
           alien -d Win4Lin-
3.  dpkg -i win4lin_5.1.0ga-2_i386.deb
4.  Go to /opt/win4lin, run ./postinst_rpm.sh as root
5.  Do license stuff

Step 4 is probably the one you're missing.

There are other ways to do the installation (eg, rpm --nodeps ...) but
I haven't tried them and don't know what other effects they might
have.  As always, YMMV.


Martin Hillyer
Powered by Debian GNU/Linux 2.2.18
Communications by mutt-1.3.12i
When Marriage is Outlawed, Only Outlaws will have Inlaws.

Reply to: