[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X error

On Tue, Jan 02, 2001 at 10:28:51AM -0800, Bob Nielsen wrote:
> On Tue, Jan 02, 2001 at 12:22:39AM -0800, kmself@ix.netcom.com wrote:
> > on Mon, Jan 01, 2001 at 09:28:57PM -0800, Bob Nielsen (nielsen@oz.net) wrote:
> > > I had a problem with woody several days ago where X would die
> > > immediately after starting, before the window manager took over.  In
> > > trying to fix it, I really messed up my X installation, so I decided to
> > > downgrade to potato and did a fresh installation of 2.2r2.  I did this
> > > and everything was working fine (including X).
> > > 
> > > Since I had started with a somewhat minimal installation I just added a
> > > lot of new packages and now X dies immediately after starting with no
> > > messages, which is the same behaviour I had before with woody.
> > > 
> > > System is a K6/2-350 with 128 MB, Cirrus 5430-based video card with
> > > 2048k videoram.  
> > > 
> > > Any ideas as to where I should be looking?
> > 
> > How are you starting X?  Command line or /etc/init.d scripts?  Find an
> > appropriate .xsession-errors file lying around anywhere?
> I use startx on the command line.  There is no .xsession-errors (I
> think that only exists in X 4.x).
> Funny thing is that I can run win4lin with the fwin command with no
> problems.  I just can't start an X session by itself.  I've tried
> different window managers with no effect.  This is what occurred with
> woody (running xserver-svga, not xserver-xfree86, since that appears to
> be slightly broken and won't support 1024x768 resolution on my card).
> There is a slight difference in what happens with potato and what
> happened with woody--in potato when it dies the line "waiting for X
> server to shut down" gets written, while in woody that message did not
> show up.
> I tried reinstalling xserver-common, xserver-svga, xfree86-common,
> xbase-clients and xlib6g, but that made no difference.  I think I'll
> try uninstalling the X apps I added and see if the problem can be
> traced to the existence of a specific package, but I doubt it will
> help.

OK, removing most of the added X applications (I kept xterm and
netscape) and now X is working again.  I guess I need to reinstall them
one-by-one to figure out which one is the culprit!


Reply to: