[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian 2.2: download stops during "apt-get update"

I still haven't been able to get 2.2 to network properly.  A suggestion
was a possible hardware problem.  I don't see how this would explain
the problem.  If I boot off the harddrive with Debian 1.3, everything
works fine.  Booting off the harddrive with Debian 2.2 and the problem
shows up.  No hardware changes.  Also, when the download hangs, I can
still access the Internet (ping, ftp, etc.).

Anyway, I tried a clean install again and this time only installed the
serial and ppp modules and tried downloading the system again.  The
download still hangs after about 30k and times out.  The network is
still up.  I can ping the Internet.  I can ping the site I am
downloading from.  I can restart the download (tried using both apt-get
and ftp with the same result) which begins again, but times out again
after downloading some more.

I got ipgrab and tcpdump to download (restarting each time the download
hung).  They don't show me anything unusual (not that I would know it
if they did ;).  The only thing I see is with plog which shows the
following at just about the time the lights stop flashing on the modem:

rcvd [Compressed date] 00 37 1e ...
sent [CCP ResetReq id=0x6]
rcvd [CCP ResetAck id=0xb]

The numeric values vary with each occurance.  Also, ipgrab shows after
each timeout a new port is used to connect to my machine with.  This
may all be normal stuff.

I would appreciate any help this group could offer in troubleshooting


> I am in the process of trying to upgrade my computers to 2.2.  My
> workstation was running 2.0 and my server was running 1.3.  When I upgraded
> my workstation, I started having network problems.  Downloading files seems
> to frequently stop after 1-5 minutes.  The network is still up, pinging the
> source still works.  Other connections (e.g., http) still are running. 
> There is just no download occurring!  Sometimes everything works great.  My
> slrnpull cron job hasn't worked since the upgrade because it aborts after
> downloading one group and part way through the next group with the error
> "***Connection to news.concentric.net lost. Performing shutdown.".
> I thought there might be some problem with the server (acting as my Internet
> gateway) running 1.3, and since I needed to install a larger hard drive
> anyway, I did a clean install of 2.2 on the server.  Everything goes great
> until I get to the point of downloading the rest of the system using ftp and
> apt-get.  When I try to do "apt-get update" the same downloading problem
> occurs and apt-get times out without getting the full packages listing.
> I've been using Linux for a couple years now, but I'm no expert.  Usually
> the Debian installs and upgrades work without any big problems.  I'm not
> sure how to go about troubleshooting this one.  The log files don't show
> anything curious.  I've checked the archives of this mailing list, but
> haven't found any mention of a similar problem.  So it must be something I'm
> not doing correctly.  Both machines are using 486 processors.  They use
> different network cards (NE2000 and HP J2405A).
> Last night I upgraded my workstation to 2.2r2, but the problem persists.  I
> would appreciate any help this group can provide.
> Thanks,
>    Jeff
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: