[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Samba and printing

I set up a Debian box with lprng, magicfilter and a HP LJ 4000t as a
Printing from Linux rockz!
The prob is we're forced to use a Access pseudo App unter Windos
so I tried to set up a samba config for printing and failed :-((

My configuration looks like this:


   workgroup = Telelev
   guest account = nobody
   keep alive = 30
   os level = 200
   security = share
   netbios name = killercrush - Printserver-Technik
   security = share
   printing = lprng
   printcap name = /etc/printcap
   load printers = yes
   log file = /var/log/samba-log.%m
   lock directory = /var/lock/samba
   socket options = TCP_NODELAY
   map to guest = Bad User
   interfaces =
   wins server =
        guest ok = yes
        print command =       /usr/bin/lpr  -U%U@%H -P%p -r %s
        lpq command   =       /usr/bin/lpq  -U%U@%H -P%p
        lprm command  =       /usr/bin/lprm -U%U@%H -P%p %j
        lppause command =     /usr/sbin/lpc -U%U@%H hold %p %j
        lpresume command =    /usr/sbin/lpc -U%U@%H release %p %j
        queuepause command =  /usr/sbin/lpc -U%U@%H -P%p stop
        queueresume command = /usr/sbin/lpc -U%U@%H -P%p start
     path = /var/spool/lpd/raw
     printer name = raw
     writable = yes
     public = yes
     printable = yes
     print command = lpr -b -Praw %s

lp|hplj4000t|HP Laserjet 4000T:\

I tried to print through the raw and lp entry.
Windos NT says that the printer is not configured
and that I've to print a Testpage or to reinstall the

Printing the Testpage fails.


Reply to: