[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with pppd and Kernel

Daniel Christle wrote:
> Hi there,
> I am new to Debian, having used Slack previously. I am having problems
> with getting my Internet connection to work under Debian 2.2. I run pon
> <nameofProvider> and get a ppp not supported by kernel message. Check that
> the modules physically exist and they do. I run the command
> /sbin/modprobe -v ppp and get another message that states insmod
> unsuccessful as there is a kernel mismatch. It tells me that the modules
> are for kernel 2.2.16, yet I have kernel 2.2.17.
> Any ideas on how to solve this? Any help will be greatly appreciated.
> Daniel Christle


Did you compile the kernel or are you using the stock image? Are you
using potato or woody (stable or unstable)?

While trying to get my potato box to run a pppoe connection with a
2.2.17 kernel, I saw wonky stuff that hadn't been present with a 2.2.15
kernel. Particularly, ppp would transmit a few packets and then just die
after successfully connecting to my ISP. Since this was the *potato*
distribution, the kernel was actually 2.2.17-pre-6. I finally upgraded
the whole box to *woody*, and compiled the 2.2.17 kernel from that
distribution -- which is the 2.2.17-1 kernel source. This works like a
charm. All is happiness and light again, though I've no clear idea why.

I realize that this may not be germane to your situation. But for what
it's worth, I encountered some inexplicable problems with ppp using the
2.2.17-pre-6 kernel source that simply went away with the 2.2.17-1
source in the woody distro. I suggest you upgrade if you haven't done
so. If you already have, then I'd ignore me and pay attention to someone
who really knows. ;-)


Reply to: