[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with the 3Com 3c905B NIC



I got this OEM 3Com 3c905B card and added it to my system (ABIT-BH6,
Celeron 300A) which already has a generic 10/100 PCI NIC that has thus
far been working perfectly with Rogers@Home service.

BTW, the other NIC that works fine is detected by kernel as:

eth1: Macronix 98715 PMAC rev 37 at 0xe400, 00:80:C6:EE:A2:E3, IRQ 10.

I compiled in support for the card into the kernel that I am using,
2.2.17 from sources with no patches, using the 3c59x.c driver. The card
is detected fine by the kernel at boot time as follows:

eth0: 3Com 3c905B Cyclone 100baseTx at 0xe800,  00:01:02:ca:90:fb, IRQ 11
  8K byte-wide RAM 5:3 Rx:Tx split, 10baseT interface.
  Enabling bus-master transmits and whole-frame receives.

(BTW, I forced the card into 10baseT mode using a 3Com dos utility that
I got from their web site)

The link led at the back of my cable modem (Terayon Tera Pro) is light
green. The 10baseT (link?) led on the 3Com NIC is lit green as well. I
am using a CAT5-UTP cable with RJ-45 connectors to connect the 3Com NIC
to the cable modem (same cable with which the Rogers supplied generic
10/100 NIC works without any problems).

When I try and ping any host e.g. www.leitch.com, the Send and Receive
lights on the cable modem blink almost simultaneously every 1
sec. apart. But there aren't any blinking lights on the back of the
NIC.

I am at my wits end trying to figure out why this 3Com 3c905B NIX isn't
working. I have tried the following (not in the same order) to debug/fix
this problem:

(1) upgraded the BIOS on my ABIT BH6 motherboard to the latest one
available

(2) inserted the 3Com NIC into different PCI slots on the mobo

(3) took out my SoundBlaster PCI128 sound card from the motherboard,
then subsequently took out the other generic NIC from my system so that
the only PCI card in my system was the 3Com NIC

(4) changed the NIC configuration using a 3Com dos utility from
the default autosense/autonegotiate to 10Base-T media type

(5) had a Rogers tech verify that there wasn't any problem with my cable
modem (which BTW works fine with their supplied generic 10/100 NIC)

Neither of the above solved the problem. I am using a static IP
configuration with values set in /etc/network/interfaces.

I am having the exact same problems with this same NIC in a second
machine - my brand new PIII machine which also has the same NIC.

I'd appreciate any information/comments/suggestions in how to fix this
problem. I am using kernel-2.2.17 with the latest woody packages.

If I am unable to fix this problem in the next couple of days, I will be
replacing these 2 NICs with some other 10/100 ones. Any recommendations
for a good PCI 10/100 NIC that "just works" with the current 2.2.17
kernels with compiled-in support and without requiring any extra module
arguments/parameters ? I'll be looking to get 2 of these NICs of the
same brand and model initially.

TIA.

-- 
Salman Ahmed
ssahmed AT pathcom DOT com



Reply to: