[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: using my /dev items - playing CDs

Do you have read permission for the device where the cdrom is
connected (/dev/hdc, for example)?

On Sat, Aug 19, 2000 at 11:21:40PM -0500, John Reinke wrote:
> I'm getting very close - sounds now work thanks to the tips below. I still
> can't get music CDs to work. They will work when I log into X as root...
> but that's not good.
> When I start the CD player, it says:
> Error accessing cdrom device.
> Please check to make sure cdrom drive support is compiled into the kernel,
> and that you have permission to access the device.
> Reason: Permission denied
> Like I said before, it will play CDs when I log into X as root. I tried
> changing the group of the CD program (gtcd) to audio, since my username is
> now a member of the audio group, but it still gave the same error.
> Any suggestions are certainly welcome,
> John
> Eric G. Miller wrote:
> >On Sat, Aug 19, 2000 at 09:20:39PM -0500, John Reinke wrote:
> >> I've been setting up my sound, and I still don't have everything up and
> >> running yet. I've noticed that the sound effects for Enlightenment won't
> >> start until esd (Enlightenment sound daemon) is running, and I can only
> >> start that as root. Is this because /dev/audio (and therefore esd) is only
> >> accessible by root?
> >
> >As root:
> >$ adduser <username> audio
> >
> >> I've had a suggestion to use groups to provide access to devices. Is this
> >> the standard (and "safe") way to handle using sound for mutiple users while
> >> using X? It doesn't seem that this is a common problem, so I feel I'm
> >> missing something.
> >>
> >> Also, I wanted to test listening to a CD, but somehow I can no longer
> >> access CDs. The Debian install created /cdrom (I assume this is instead of
> >> /mnt/cdrom) and there is no /dev/cdrom to mount in the first place. It says:
> >>
> >> mount: special device /dev/cdrom does not exist
> >
> >/dev/cdrom is a symbolic link to the real device. Just create it like:
> >$ ln -s /dev/hdc /dev/cdrom
> >
> >You'll need to figure out which device is really your cdrom. But there
> >aren't too many if it's IDE (/dev/hd[a-d] usually).
> >
> >And, yes, Debian uses /cdrom and /floppy instead of /mnt/cdrom and
> >/mnt/floppy.  You can change that if you like by creating two
> >directories under /mnt and then updating /etc/fstab accordingly.  Some
> >Debian packages may expect the default, but I can't think of any...
> >
> >> My CD worked perfectly in a previous installation. I now am using a
> >> week-old net-install of potato.
> >--
> >
> >
> >--
> >Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org <
> >/dev/null
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Bob Nielsen, N7XY                          nielsen@oz.net
Bainbridge Island, WA                      http://www.oz.net/~nielsen

Reply to: