[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems updating development kernel / init not found


I'm using Debian unstable with the 2.3.42 kernel and try to update to 2.4-test4 or
any other reasonable new kernel. 
The problem is that the new kernels wont boot, I always get a "Kernel panic: init not
found" message when booting the new kernel. The same problem occurs with all other
newer kernels, for example I tried two of the 2.3.50 series. 

- both kernels are in the same lilo.conf, the configuration is identical (same
root&boot partion and so on, only image and label are different)
- the kernel seems to mount the root partition correctly ("VFS: Mounted root (ext2
filesystem) readonly."), so I guess I have the ext2 file systems and IDE drivers in
the kernel. The partitions are displayed, too.
- I tried to specify another init process, for example init=/bin/bash, without any

What else can I do? Have there been any changes in the ext2 file system that can
prevent newer kernels from reading my boot partition?


Reply to: