[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to print? (Xerox DocuPrint C15)

On Wed, 12 Jul 2000, Horacio MG wrote:

> > Personally, I prefer magicfilter, but the important question is not
> > taste but whether one of the packages contains a filter that will
> > translate into a language your Xerox DocuPrint knows. Have a look at
> > both.
> I just tried apsfilter, went through the apsfilterconfig script and when
> I try to test print I got an error.  You can see the error in the
> apsfilter.log attached file (where it says "tubería rota" it translates
> to "broken pipe").
> Anyway, I purged apsfilter and tried magicfilter.  Ran magicfilterconfig
> --force:
> Printer name  Short name Spool dir            Device     Input filter
> -----------------------------------------------------------------------
> XeroX DocuPri xerox      /var/spool/lpd/xerox /dev/lp0   ljet4l       *
> I created the xerox/ directory for spooling (shouldn't I change the
> group owner to lp instead of root?);

Perhaps, but I think it should work as it is.

> >From the list of "filters" it gave me, I chose the default one (ljet4l).
> I know this is not a laserjet, but I don't know which one to try, as
> there was none close to cdj550, which is the one I found supports these
> xerox models:
>  Xerox Document Homecentre
>  Xerox DocuPrint C5 & C6
>  Xerox Workcentre 450cp
>  Xerox xj6c

it is called dj550c in magicfilter. ljet4l probably won't work.

> The resulting /etc/printcap looks like:
> lp|xerox|XeroX DocuPrint C15:\
>         :lp=/dev/lp0:sd=/var/spool/lpd/xerox:\
> 	:sh:pw#80:pl#72:px#1440:mx#0:\
> 	:if=/etc/magicfilter/ljet4l-filter:\
> 	:af=/var/log/lp-acct:lf=/var/log/lp-errs:
> This is not woking the same now:
> $ lpq
> lpq: lp0: unknown printer
> also:
> $ lpc status
> lp:
>         queuing is enabled
>         printing is enabled
>         no entries
>         no daemon present
> which should mean that the lpd daemon is not active?
> $ ps aux
> ...
> root      2548  0.0  0.4  1444   596  ?  S    12:21   0:00 /usr/sbin/lpd

from the "unknown printer" error above I suspect you have set the
PRINTER environment variable to lp0 ?. With your printcap entry, this is
wrong. One of

export PRINTER=lp
export PRINTER=xerox
export PRINTER="XeroX DocuPrint C15"

or, since lp is the default anyway,


would work. Noone except lpd ever wants to know to which interface
(say: kernel device) your printer is attached, and lpd can read it off
from printcap. Everyone else just needs to know the name (or one of the
names) of the correct printcap entry and this name is what lpr's -P option

This may have been the problem with apsfilter, too, but the error message
isn't very informative. "broken pipe" usually means that one of the
(many) programs in the chain in which the printer data is passed on has
died unexpectedly.

> > Does that mean your Xerox is HP DeskJet compatible? If so, both
> > magicfilter and apsfilter will work.
> I don't know.  I just called to the customer service and asked them what
> driver they use.  They couldn't tell me and they'll have a tech to call
> me back.

If the dj550c/cdj550 driver works then it is compatible to a DeskJet 550

As to your question about ghostscript: yes, the Aladdin version should be
newer. Aladdin releases older versions under the GPL after some time,
these become GNU ghostscript.

On the other hand, GNU ghostscript is free software, and (therefore :) the
GNU release may contain bugfixes and additions committed by "third
parties" and not found in Aladdin releases.

Bj"orn Brill <brill@fs.math.uni-frankfurt.de>
Frankfurt am Main, Germany

Reply to: